Login to My Account   Partners  
Click to change countryUnited States (change)
 
WPA2 Security KRACK Attack Notice

10/17/2017

A WPA2 vulnerability from the KRACK Attack was revealed on Oct. 16, 2017. This attack affects the entire wireless industry, but affected devices can be patched with a security update. TRENDnet is currently investigating the issue and we are working with our semiconductor chipset partners on patches. Updates will be posted on product download pages once available.

Note:
The WPA2 KRACK main attack targets client devices against the 4-way handshake, and requires physical proximity. Wi-Fi routers and wireless access points are not affected by this attack. However, to reduce the risk of attacks against your router or access points, disable client functionality and fast roaming (802.11r). For home users, be sure to keep client devices, such as laptops and smartphones, updated.